<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [GTK] Update WOFF2 decoder"
href="https://bugs.webkit.org/show_bug.cgi?id=162608#c8">Comment # 8</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [GTK] Update WOFF2 decoder"
href="https://bugs.webkit.org/show_bug.cgi?id=162608">bug 162608</a>
from <span class="vcard"><a class="email" href="mailto:fred.wang@free.fr" title="Frédéric Wang (:fredw) <fred.wang@free.fr>"> <span class="fn">Frédéric Wang (:fredw)</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=289962&action=diff" name="attach_289962" title="Patch, v3">attachment 289962</a> <a href="attachment.cgi?id=289962&action=edit" title="Patch, v3">[details]</a></span>
Patch, v3
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=289962&action=review">https://bugs.webkit.org/attachment.cgi?id=289962&action=review</a>
Yes, this looks good to me with Michael's comments addressed.
<span class="quote">>> Source/WebCore/platform/graphics/WOFFFileFormat.cpp:100
>> + bool Write(const void *data, size_t n)
>
> void* data, not void *data
>
> Is this a virtual method? If so you need to mark it override. If not, it should be named write with a lowercase W, since WebKit methods are camelCase.</span >
Yes, they are pure virtual and should indeed be marked override.
<a href="https://github.com/google/woff2/blob/4e698b8c6c5e070d53c340db9ddf160e21070ede/src/woff2_out.h#L59">https://github.com/google/woff2/blob/4e698b8c6c5e070d53c340db9ddf160e21070ede/src/woff2_out.h#L59</a></pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>