<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>Bug ID</th>
<td><a class="bz_bug_link
bz_status_NEW "
title="NEW - Move skipLeadingAndTrailingWhitespace in MathMLElement.cpp to HTMLParserIdioms.cpp"
href="https://bugs.webkit.org/show_bug.cgi?id=160172">160172</a>
</td>
</tr>
<tr>
<th>Summary</th>
<td>Move skipLeadingAndTrailingWhitespace in MathMLElement.cpp to HTMLParserIdioms.cpp
</td>
</tr>
<tr>
<th>Classification</th>
<td>Unclassified
</td>
</tr>
<tr>
<th>Product</th>
<td>WebKit
</td>
</tr>
<tr>
<th>Version</th>
<td>WebKit Nightly Build
</td>
</tr>
<tr>
<th>Hardware</th>
<td>Unspecified
</td>
</tr>
<tr>
<th>OS</th>
<td>Unspecified
</td>
</tr>
<tr>
<th>Status</th>
<td>NEW
</td>
</tr>
<tr>
<th>Severity</th>
<td>Normal
</td>
</tr>
<tr>
<th>Priority</th>
<td>P2
</td>
</tr>
<tr>
<th>Component</th>
<td>HTML DOM
</td>
</tr>
<tr>
<th>Assignee</th>
<td>webkit-unassigned@lists.webkit.org
</td>
</tr>
<tr>
<th>Reporter</th>
<td>ddkilzer@webkit.org
</td>
</tr>
<tr>
<th>CC</th>
<td>cdumez@apple.com, darin@apple.com, fred.wang@free.fr
</td>
</tr></table>
<p>
<div>
<pre>Based on <a class="bz_bug_link
bz_status_RESOLVED bz_closed"
title="RESOLVED FIXED"
href="show_bug.cgi?id=160111#c14">Bug 160111 Comment #14</a>, we should:
- Move skipLeadingAndTrailingWhitespace() into the HTMLParserIdioms class,
- Rename it to overload stripLeadingAndTrailingHTMLSpaces(), and
- Change the argument from const StringView& to StringView.
Eventually, we should remove the stripLeadingAndTrailingHTMLSpaces(const String&) method in favor of the StringView method.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>