<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [GTK][Threaded Compositor] Web view background colors don't work"
href="https://bugs.webkit.org/show_bug.cgi?id=159465#c3">Comment # 3</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [GTK][Threaded Compositor] Web view background colors don't work"
href="https://bugs.webkit.org/show_bug.cgi?id=159465">bug 159465</a>
from <span class="vcard"><a class="email" href="mailto:cgarcia@igalia.com" title="Carlos Garcia Campos <cgarcia@igalia.com>"> <span class="fn">Carlos Garcia Campos</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=159465#c2">comment #2</a>)
<span class="quote">> Comment on <span class=""><a href="attachment.cgi?id=283004&action=diff" name="attach_283004" title="Patch">attachment 283004</a> <a href="attachment.cgi?id=283004&action=edit" title="Patch">[details]</a></span>
> Patch
>
> View in context:
> <a href="https://bugs.webkit.org/attachment.cgi?id=283004&action=review">https://bugs.webkit.org/attachment.cgi?id=283004&action=review</a>
>
> > Source/WebKit2/Shared/CoordinatedGraphics/threadedcompositor/ThreadedCompositor.cpp:87
> > + m_drawsBackground = drawsBackground;
>
> This is fine as it is, but my style is to capture only protectedThis and use
> it explicitly in the lambda, instead of capturing both this and
> protectedThis. I'm not sure which style is more prevalent in WebKit code.</span >
There's no consensus last time we discussed it, some people (like me) prefer to also capture this to make the lambda body easier to read without having to use protectedThis-> everywhere.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>