<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><span class="vcard"><a class="email" href="mailto:calvaris@igalia.com" title="Xabier Rodríguez Calvar <calvaris@igalia.com>"> <span class="fn">Xabier Rodríguez Calvar</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - [GStreamer][GL] crash within triggerRepaint"
href="https://bugs.webkit.org/show_bug.cgi?id=159552">bug 159552</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #283139 Flags</td>
<td>review?
</td>
<td>review+
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [GStreamer][GL] crash within triggerRepaint"
href="https://bugs.webkit.org/show_bug.cgi?id=159552#c7">Comment # 7</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [GStreamer][GL] crash within triggerRepaint"
href="https://bugs.webkit.org/show_bug.cgi?id=159552">bug 159552</a>
from <span class="vcard"><a class="email" href="mailto:calvaris@igalia.com" title="Xabier Rodríguez Calvar <calvaris@igalia.com>"> <span class="fn">Xabier Rodríguez Calvar</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=283139&action=diff" name="attach_283139" title="patch">attachment 283139</a> <a href="attachment.cgi?id=283139&action=edit" title="patch">[details]</a></span>
patch
<span class="quote">> I understand the concerns about reducing performance but if there isn't we
> should create a function to do something like:
>
> {
> auto weakThis = player.createWeakPtr();
> RunLoop::main().runNowIfMainThreadOrdispatch([weakThis]) {
> if (weakThis)
> weakThis->m_player->sizeChanged();
> });
> }
>
> Otherwise I think we are creating these code structures and IMHO it makes
> code hard to read.</span >
Let's not block landing this because of this nit, but please, open a new bug about this.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>