<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Too much duplicated code in LayerTreeHosts implementations"
href="https://bugs.webkit.org/show_bug.cgi?id=159144#c5">Comment # 5</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Too much duplicated code in LayerTreeHosts implementations"
href="https://bugs.webkit.org/show_bug.cgi?id=159144">bug 159144</a>
from <span class="vcard"><a class="email" href="mailto:yoon@igalia.com" title="Gwang Yoon Hwang <yoon@igalia.com>"> <span class="fn">Gwang Yoon Hwang</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=282123&action=diff" name="attach_282123" title="Try to fix EFL build">attachment 282123</a> <a href="attachment.cgi?id=282123&action=edit" title="Try to fix EFL build">[details]</a></span>
Try to fix EFL build
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=282123&action=review">https://bugs.webkit.org/attachment.cgi?id=282123&action=review</a>
<span class="quote">> Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedLayerTreeHost.cpp:207
> + UNUSED_PARAM(size);</span >
Maybe using ASSERT_NOT_REACHED would be nice to use here.
<span class="quote">> Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/ThreadedCoordinatedLayerTreeHost.h:65
> + class CompositorClient final : public ThreadedCompositor::Client {</span >
What about to add WTF_MAKE_NONCOPYABLE to make sure?
<span class="quote">> Source/WebKit2/WebProcess/WebPage/LayerTreeHost.h:73
> virtual void sizeDidChange(const WebCore::IntSize& newSize) = 0;</span >
What about change the name of it to the viewportSizeChanged, as we discussed earlier?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>