<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - REGRESSION(r202337) [WebRTC] Crash when loading html5test.com"
href="https://bugs.webkit.org/show_bug.cgi?id=159145#c5">Comment # 5</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - REGRESSION(r202337) [WebRTC] Crash when loading html5test.com"
href="https://bugs.webkit.org/show_bug.cgi?id=159145">bug 159145</a>
from <span class="vcard"><a class="email" href="mailto:achristensen@apple.com" title="Alex Christensen <achristensen@apple.com>"> <span class="fn">Alex Christensen</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=282224&action=diff" name="attach_282224" title="Proposed patch">attachment 282224</a> <a href="attachment.cgi?id=282224&action=edit" title="Proposed patch">[details]</a></span>
Proposed patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=282224&action=review">https://bugs.webkit.org/attachment.cgi?id=282224&action=review</a>
<span class="quote">> Source/WebCore/platform/mediastream/MediaEndpoint.cpp:56
> +class NullMediaEndpoint : public MediaEndpoint {</span >
I think EmptyMediaEndpoint would be a better name.
<span class="quote">> Source/WebCore/platform/mediastream/MediaEndpoint.cpp:80
> + return std::unique_ptr<MediaEndpoint>(new NullMediaEndpoint(client));</span >
make_unique. Also, this function is not necessary. Just use std::make_unique instead of this.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>