<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Use a regex to check if a test step is for JavaScriptCore"
href="https://bugs.webkit.org/show_bug.cgi?id=159224#c3">Comment # 3</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Use a regex to check if a test step is for JavaScriptCore"
href="https://bugs.webkit.org/show_bug.cgi?id=159224">bug 159224</a>
from <span class="vcard"><a class="email" href="mailto:ap@webkit.org" title="Alexey Proskuryakov <ap@webkit.org>"> <span class="fn">Alexey Proskuryakov</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=282279&action=diff" name="attach_282279" title="Patch">attachment 282279</a> <a href="attachment.cgi?id=282279&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=282279&action=review">https://bugs.webkit.org/attachment.cgi?id=282279&action=review</a>
<span class="quote">> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotCombinedQueueView.js:112
> - } else if (mostRecentFinishedIteration.failedTestSteps.length === 1 && ["jscore-test", "webkit-32bit-jsc-test", "webkit-jsc-cloop-test"].indexOf(mostRecentFinishedIteration.failedTestSteps[0].name) >= 0) {
> + } else if (mostRecentFinishedIteration.failedTestSteps.length === 1 && /jsc/.test(mostRecentFinishedIteration.failedTestSteps[0].name) === true) {</span >
Would it make sense to make sure that "test" is in the name too? That would decrease the chances of something like "build-jsc" or "configure-jsc-dependencies" to confuse the logic.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>