<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><span class="vcard"><a class="email" href="mailto:zan@falconsigh.net" title="Zan Dobersek <zan@falconsigh.net>"> <span class="fn">Zan Dobersek</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - [Soup] Clean up SocketStreamHandle soup implementation"
href="https://bugs.webkit.org/show_bug.cgi?id=159024">bug 159024</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #281842 Flags</td>
<td>review?
</td>
<td>review+
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - [Soup] Clean up SocketStreamHandle soup implementation"
href="https://bugs.webkit.org/show_bug.cgi?id=159024#c2">Comment # 2</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - [Soup] Clean up SocketStreamHandle soup implementation"
href="https://bugs.webkit.org/show_bug.cgi?id=159024">bug 159024</a>
from <span class="vcard"><a class="email" href="mailto:zan@falconsigh.net" title="Zan Dobersek <zan@falconsigh.net>"> <span class="fn">Zan Dobersek</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=281842&action=diff" name="attach_281842" title="Patch">attachment 281842</a> <a href="attachment.cgi?id=281842&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=281842&action=review">https://bugs.webkit.org/attachment.cgi?id=281842&action=review</a>
<span class="quote">> Source/WebCore/platform/network/soup/SocketStreamHandleSoup.cpp:223
> + g_source_set_callback(m_writeReadySource.get(), reinterpret_cast<GSourceFunc>(writeReadyCallback), this, [](gpointer handle) {
> + static_cast<SocketStreamHandle*>(handle)->deref();
> + });</span >
IMO the lambda would be more readable if its header was also placed on its own line, and all three lines being indented by 4 spaces compared to the start of this expression.
The rest of this patch adopts the leaked pointer into a RefPtr<> wrapper, this should do the same.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>