<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - WebRTC: Imlement MediaEndpointPeerConnection::setRemoteDescription()"
   href="https://bugs.webkit.org/show_bug.cgi?id=158467#c3">Comment # 3</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - WebRTC: Imlement MediaEndpointPeerConnection::setRemoteDescription()"
   href="https://bugs.webkit.org/show_bug.cgi?id=158467">bug 158467</a>
              from <span class="vcard"><a class="email" href="mailto:adam.bergkvist&#64;ericsson.com" title="Adam Bergkvist &lt;adam.bergkvist&#64;ericsson.com&gt;"> <span class="fn">Adam Bergkvist</span></a>
</span></b>
        <pre>(In reply to <a href="show_bug.cgi?id=158467#c2">comment #2</a>)
<span class="quote">&gt; Comment on <span class=""><a href="attachment.cgi?id=280807&amp;action=diff" name="attach_280807" title="Proposed patch">attachment 280807</a> <a href="attachment.cgi?id=280807&amp;action=edit" title="Proposed patch">[details]</a></span>
&gt; Proposed patch
&gt; 
&gt; View in context:
&gt; <a href="https://bugs.webkit.org/attachment.cgi?id=280807&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=280807&amp;action=review</a>
&gt; 
&gt; &gt; LayoutTests/fast/mediastream/RTCTrackEvent-constructor.html:64
&gt; &gt; +                debug(&quot;Dictionary members receiver, track and transceiver are not nullable&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { receiver: null, track: track, transceiver: transceiver})&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { receiver: receiver, track: null, transceiver: transceiver})&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { receiver: receiver, track: track, transceiver: null})&quot;);
&gt; &gt; +                debug(&quot;&quot;);
&gt; &gt; +
&gt; &gt; +                debug(&quot;Dictionary members receiver, track and transceiver are required&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { track: track, transceiver: transceiver})&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { receiver: receiver, transceiver: transceiver})&quot;);
&gt; &gt; +                shouldThrow(&quot;new RTCTrackEvent('eventType', { receiver: receiver, track: track})&quot;);
&gt; &gt; +                debug(&quot;&quot;);
&gt; 
&gt; Please add a FIXME and a bug # about these failures.</span >

Fixed.

Bug: <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Bindings: [InitializedByEventConstructor] should support required and non-nullable dictionary members"
   href="show_bug.cgi?id=158536">https://bugs.webkit.org/show_bug.cgi?id=158536</a>

<span class="quote">&gt; &gt; Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:389
&gt; &gt; +
&gt; 
&gt; Minor nit: I find the blank line here slightly distracting</span >

Gone. :)

<span class="quote">&gt; &gt; Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:401
&gt; &gt; +
&gt; &gt; +
&gt; 
&gt; Ditto.</span >

Fixed.

<span class="quote">&gt; &gt; Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:412
&gt; &gt; +    for (unsigned i = 0; i &lt; mediaDescriptions.size(); ++i) {
&gt; &gt; +        PeerMediaDescription* mediaDescription = mediaDescriptions[i].get();
&gt; 
&gt; Nit: can you use a modern for loop here?</span >

True. Fixed.

<span class="quote">&gt; &gt; Source/WebCore/Modules/mediastream/RTCTrackEvent.idl:37
&gt; &gt; +   [InitializedByEventConstructor] readonly attribute MediaStream[] streams;
&gt; 
&gt; Can you use &quot;attribute sequence&lt;MediaStream&gt; streams&quot; instead?</span >

A sequence can't be an interface attribute [1].

[1] <a href="http://heycam.github.io/webidl/#idl-sequence">http://heycam.github.io/webidl/#idl-sequence</a>

<span class="quote">&gt; &gt; Source/WebCore/platform/mock/MockMediaEndpoint.cpp:140
&gt; &gt; +        for (auto&amp; p : defaultPayloads) {
&gt; 
&gt; Nit: a single letter variable name in a modern for loop - such an
&gt; anachronism :-)
&gt; 
&gt; Might as well spell out the variable.</span >

Ops. :) Let's use payload since defaultPayload is taken.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>