<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - WebRTC: Imlement MediaEndpointPeerConnection::setRemoteDescription()"
href="https://bugs.webkit.org/show_bug.cgi?id=158467#c2">Comment # 2</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - WebRTC: Imlement MediaEndpointPeerConnection::setRemoteDescription()"
href="https://bugs.webkit.org/show_bug.cgi?id=158467">bug 158467</a>
from <span class="vcard"><a class="email" href="mailto:eric.carlson@apple.com" title="Eric Carlson <eric.carlson@apple.com>"> <span class="fn">Eric Carlson</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=280807&action=diff" name="attach_280807" title="Proposed patch">attachment 280807</a> <a href="attachment.cgi?id=280807&action=edit" title="Proposed patch">[details]</a></span>
Proposed patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=280807&action=review">https://bugs.webkit.org/attachment.cgi?id=280807&action=review</a>
<span class="quote">> LayoutTests/fast/mediastream/RTCTrackEvent-constructor.html:64
> + debug("Dictionary members receiver, track and transceiver are not nullable");
> + shouldThrow("new RTCTrackEvent('eventType', { receiver: null, track: track, transceiver: transceiver})");
> + shouldThrow("new RTCTrackEvent('eventType', { receiver: receiver, track: null, transceiver: transceiver})");
> + shouldThrow("new RTCTrackEvent('eventType', { receiver: receiver, track: track, transceiver: null})");
> + debug("");
> +
> + debug("Dictionary members receiver, track and transceiver are required");
> + shouldThrow("new RTCTrackEvent('eventType', { track: track, transceiver: transceiver})");
> + shouldThrow("new RTCTrackEvent('eventType', { receiver: receiver, transceiver: transceiver})");
> + shouldThrow("new RTCTrackEvent('eventType', { receiver: receiver, track: track})");
> + debug("");</span >
Please add a FIXME and a bug # about these failures.
<span class="quote">> Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:389
> +</span >
Minor nit: I find the blank line here slightly distracting
<span class="quote">> Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:401
> +
> +</span >
Ditto.
<span class="quote">> Source/WebCore/Modules/mediastream/MediaEndpointPeerConnection.cpp:412
> + for (unsigned i = 0; i < mediaDescriptions.size(); ++i) {
> + PeerMediaDescription* mediaDescription = mediaDescriptions[i].get();</span >
Nit: can you use a modern for loop here?
<span class="quote">> Source/WebCore/Modules/mediastream/RTCTrackEvent.idl:37
> + [InitializedByEventConstructor] readonly attribute MediaStream[] streams;</span >
Can you use "attribute sequence<MediaStream> streams" instead?
<span class="quote">> Source/WebCore/platform/mock/MockMediaEndpoint.cpp:140
> + for (auto& p : defaultPayloads) {</span >
Nit: a single letter variable name in a modern for loop - such an anachronism :-)
Might as well spell out the variable.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>