<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><span class="vcard"><a class="email" href="mailto:achristensen@apple.com" title="Alex Christensen <achristensen@apple.com>"> <span class="fn">Alex Christensen</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - Add event support for link preload."
href="https://bugs.webkit.org/show_bug.cgi?id=158466">bug 158466</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #280799 Flags</td>
<td>review?
</td>
<td>review-
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Add event support for link preload."
href="https://bugs.webkit.org/show_bug.cgi?id=158466#c38">Comment # 38</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Add event support for link preload."
href="https://bugs.webkit.org/show_bug.cgi?id=158466">bug 158466</a>
from <span class="vcard"><a class="email" href="mailto:achristensen@apple.com" title="Alex Christensen <achristensen@apple.com>"> <span class="fn">Alex Christensen</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=280799&action=diff" name="attach_280799" title="Patch">attachment 280799</a> <a href="attachment.cgi?id=280799&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=280799&action=review">https://bugs.webkit.org/attachment.cgi?id=280799&action=review</a>
<span class="quote">> Source/WebCore/loader/LinkPreloadResourceClients.cpp:2
> + * Copyright 2016 The Chromium Authors. All rights reserved.</span >
Did the chromium authors write this? Is there a corresponding crbug?
<span class="quote">> Source/WebCore/loader/LinkPreloadResourceClients.h:28
> +#ifndef LinkPreloadResourceClients_h
> +#define LinkPreloadResourceClients_h</span >
#pragma once
<span class="quote">> Source/WebCore/loader/LinkPreloadResourceClients.h:81
> + return new LinkPreloadScriptResourceClient(loader, resource);</span >
This is a memory leak. There's no corresponding delete. Instead of Optional, I think we should just use std::unique_ptr
<span class="quote">> Source/WebCore/loader/cache/CachedResourceLoader.cpp:1035
> #if !PLATFORM(IOS)</span >
I think we should consider making iOS loading work more like everything else. Probably not in this patch, though.
<span class="quote">> Source/WebCore/platform/network/ResourceRequestBase.h:152
> + bool ignoreForRequestCounting() const { return m_ignoreForRequestCounting; }
> + void setIgnoreForRequestCounting(bool ignoreForRequestCounting) { m_ignoreForRequestCounting = ignoreForRequestCounting; }</span >
shouldIgnoreForeRequestCounting and setShouldIgnoreForRequestCounting might be better names. Or maybe ignoreForRequestCount to match CachedResource.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>