<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - LLInt should support other types of prototype GetById caching."
href="https://bugs.webkit.org/show_bug.cgi?id=158083#c22">Comment # 22</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - LLInt should support other types of prototype GetById caching."
href="https://bugs.webkit.org/show_bug.cgi?id=158083">bug 158083</a>
from <span class="vcard"><a class="email" href="mailto:keith_miller@apple.com" title="Keith Miller <keith_miller@apple.com>"> <span class="fn">Keith Miller</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=158083#c21">comment #21</a>)
<span class="quote">> Per your request before on inlining the getter call, I think the simplest
> way to implement it is to follow how we do it in
> PolymorphicAccess/operationGetByIdOptimize. PolymorphicAccess has the inline
> cache repatching code used in the JITs. The assembler in PolymorphicAccess
> more or less models X86 so it shouldn't be too hard to follow and translate
> to LLInt assembly. I'll also see if I can find some better information about
> the calling convention too. Let me know if you have any other questions.</span >
Also, it might be helpful to look at JSStack.h, in particular, the CallFrameHeaderEntry enum since that represents the expected layout of a JS frame at the end of the function prologue.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>