<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - PlatformDisplay crash when calling egl_terminate"
href="https://bugs.webkit.org/show_bug.cgi?id=157973#c8">Comment # 8</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - PlatformDisplay crash when calling egl_terminate"
href="https://bugs.webkit.org/show_bug.cgi?id=157973">bug 157973</a>
from <span class="vcard"><a class="email" href="mailto:mcatanzaro@igalia.com" title="Michael Catanzaro <mcatanzaro@igalia.com>"> <span class="fn">Michael Catanzaro</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=157973#c7">comment #7</a>)
<span class="quote">> Only PlatformDisplay::sharedDisplay() should ever live during the program
> lifetime, so this method would only be called only once as well. Asserting
> !m_eglDisplayInitialized at the beginning here would be helpful in that
> regard.</span >
Are you saying that this class is intended to be a singleton? If so, then it should use our normal singleton naming convention (PlatformDisplay::singleton rather than PlatformDisplay::sharedDisplay), and should have nothing in its destructor (as it would never make sense to call egl_terminate there if it's always scheduled by atexit), and terminateEGLDisplay should be called on the this pointer rather than sharedDisplay for readability. If it's not supposed to be a singleton, then the assert you suggested would be inappropriate.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>