<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body><table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>Bug ID</th>
<td><a class="bz_bug_link
bz_status_NEW "
title="NEW - Consider renaming activeDOMObjectsAreSuspended() to areActiveDOMObjectsSuspendingOrSuspended() for clarity"
href="https://bugs.webkit.org/show_bug.cgi?id=157753">157753</a>
</td>
</tr>
<tr>
<th>Summary</th>
<td>Consider renaming activeDOMObjectsAreSuspended() to areActiveDOMObjectsSuspendingOrSuspended() for clarity
</td>
</tr>
<tr>
<th>Classification</th>
<td>Unclassified
</td>
</tr>
<tr>
<th>Product</th>
<td>WebKit
</td>
</tr>
<tr>
<th>Version</th>
<td>WebKit Nightly Build
</td>
</tr>
<tr>
<th>Hardware</th>
<td>Unspecified
</td>
</tr>
<tr>
<th>OS</th>
<td>Unspecified
</td>
</tr>
<tr>
<th>Status</th>
<td>NEW
</td>
</tr>
<tr>
<th>Severity</th>
<td>Normal
</td>
</tr>
<tr>
<th>Priority</th>
<td>P2
</td>
</tr>
<tr>
<th>Component</th>
<td>WebCore JavaScript
</td>
</tr>
<tr>
<th>Assignee</th>
<td>webkit-unassigned@lists.webkit.org
</td>
</tr>
<tr>
<th>Reporter</th>
<td>adachan@apple.com
</td>
</tr></table>
<p>
<div>
<pre>ScriptExecutionContext::stopActiveDOMObjects() has always set m_activeDOMObjectsAreStopped to true before stopping the objects. For ScriptExecutionContext::suspendActiveDOMObjects(), we've recently changed it to set m_activeDOMObjectsAreSuspended to true earlier to be consistent with the stop case in <a href="http://trac.webkit.org/changeset/200965">http://trac.webkit.org/changeset/200965</a>.
Since the underlying booleans are updated right before we actually suspend/stop the objects, we should rename them to
m_activeDOMObjectsAreSuspendingOrSuspended
m_activeDOMObjectsAreStoppingOrStopped
for clarity.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>