<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:mitz&#64;webkit.org" title="mitz&#64;webkit.org &lt;mitz&#64;webkit.org&gt;"> <span class="fn">mitz&#64;webkit.org</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [iOS] Allow clients to hide the accessory view on a form input session"
   href="https://bugs.webkit.org/show_bug.cgi?id=155574">bug 155574</a>
        <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Attachment #274253 Flags</td>
           <td>review?
           </td>
           <td>review+
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [iOS] Allow clients to hide the accessory view on a form input session"
   href="https://bugs.webkit.org/show_bug.cgi?id=155574#c2">Comment # 2</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [iOS] Allow clients to hide the accessory view on a form input session"
   href="https://bugs.webkit.org/show_bug.cgi?id=155574">bug 155574</a>
              from <span class="vcard"><a class="email" href="mailto:mitz&#64;webkit.org" title="mitz&#64;webkit.org &lt;mitz&#64;webkit.org&gt;"> <span class="fn">mitz&#64;webkit.org</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=274253&amp;action=diff" name="attach_274253" title="patch v1">attachment 274253</a> <a href="attachment.cgi?id=274253&amp;action=edit" title="patch v1">[details]</a></span>
patch v1

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=274253&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=274253&amp;action=review</a>

r=me

I am not setting cq+, in case you are inspired to change the name before committing this, but I’m fine with going with this name, and possibly changing it later.

<span class="quote">&gt; Source/WebKit2/UIProcess/API/Cocoa/_WKFormInputSession.h:45
&gt; +&#64;property (nonatomic) BOOL hidesAccessoryView WK_AVAILABLE(NA, WK_IOS_TBA);</span >

This can be named better, but I don’t have a great suggestion. The things that I don’t like about this name are (a) an input session isn’t really a thing that hides (or shows) the accessory view (b) it’s strange to treat the accessory view as something that’s there by default and the input session can hide, but I understand how it would be misleading to name this property showsAccessoryView, because the accessory view isn’t shown for all input types.

Here’s a not-so-great suggestion:
    // Defaults to YES.
    &#64;property BOOL accessoryViewMayShow;</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>