<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] Arrow function syntax. Emit loading&amp;putting this/super only if they are used in arrow function"
   href="https://bugs.webkit.org/show_bug.cgi?id=153981#c5">Comment # 5</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] Arrow function syntax. Emit loading&amp;putting this/super only if they are used in arrow function"
   href="https://bugs.webkit.org/show_bug.cgi?id=153981">bug 153981</a>
              from <span class="vcard"><a class="email" href="mailto:gskachkov&#64;gmail.com" title="GSkachkov &lt;gskachkov&#64;gmail.com&gt;"> <span class="fn">GSkachkov</span></a>
</span></b>
        <pre>Comment on <span class="bz_obsolete"><a href="attachment.cgi?id=271327&amp;action=diff" name="attach_271327" title="Patch">attachment 271327</a> <a href="attachment.cgi?id=271327&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=271327&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=271327&amp;action=review</a>

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecode/UnlinkedCodeBlock.h:132
&gt;&gt; +    bool isInnerArrowFunctionUseNewTarget() { return m_arrowFunctionCodeFeatures &amp; NewTargetArrowFunctionFeature; }
&gt; 
&gt; I would name these like &quot;doAnyInnerArrowFunctionsX&quot;
&gt; i.e:
&gt; isInnerArrowFunctionUseArguments =&gt; doAnyInnerArrowFunctionsUseArguments</span >

Renamed

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:4051
&gt;&gt; +}
&gt; 
&gt; Is &quot;new.target&quot; not allowed in eval?</span >

Ups. I forget about eval. Fixed.

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.h:648
&gt;&gt; +        void emitPutThisToArrowFunctionContextScope(bool = false);
&gt; 
&gt; Style: give this bool a name, like &quot;shouldAlwaysPut&quot; or something.</span >

added

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.h:724
&gt;&gt; +        bool isArgumentsUsedInArrowFunction();
&gt; 
&gt; nit:  I would name these with &quot;Inner&quot; before &quot;In&quot;
&gt; like:
&gt; &quot;isThisUsedInInnerArrowFunction&quot;</span >

Done

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/NodesCodegen.cpp:764
&gt;&gt; +            generator.emitPutThisToArrowFunctionContextScope(true);
&gt; 
&gt; Style: We usually write code like this by assigning the boolean as a local variable and passing the local variable to the function:
&gt; ```
&gt; bool forcePutToScope = true;
&gt; generator.emitPutThisToArrowFunctionContextScope(forcePutToScope);
&gt; ```</span >

Done

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:2067
&gt;&gt; +                closestParentNonArrowFunctionNonLexicalScope()-&gt;setInnerArrowFunctionUseSuperCall();
&gt; 
&gt; An alternative to repeatedly doing a scope search here is to just propagate this information
&gt; when we pop the scope. That's usually how we propagate information upwards. Look at popScopeInternal.
&gt; Also, instead of &quot;functionBodyType != StandardFunctionBodyBlock&quot;, I think the code is easier to read
&gt; with affirmative conditions, like &quot;bodyType == ArrowExpr || bodyType == ArrowBlock&quot;</span >

Refactored to use popScope and fixed condition

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:3644
&gt;&gt; +                closestParentNonArrowFunctionNonLexicalScope()-&gt;setInnerArrowFunctionUseArgumetns();
&gt; 
&gt; If you go with the popScopeInternalApproach, this can be determined then as well when we're already iterating over all used variables.</span >

Done

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/ParserModes.h:164
&gt;&gt; +typedef uint16_t ArrowFunctionCodeFeatures;
&gt; 
&gt; this can be uint8_t</span >

Changed

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/SourceProviderCacheItem.h:47
&gt;&gt; +    unsigned innerArrowFunctionFeatures;
&gt; 
&gt; Why not ArrowFunctionCodeFeatures instead of unsigned?</span >

Fixed

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/SourceProviderCacheItem.h:92
&gt;&gt; +    unsigned innerArrowFunctionFeatures : 31;
&gt; 
&gt; ditto.</span >

Done</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>