<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:dean_johnson&#64;apple.com" title="Dean Johnson &lt;dean_johnson&#64;apple.com&gt;"> <span class="fn">Dean Johnson</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Teach dashboard code to compare non-integer revisions."
   href="https://bugs.webkit.org/show_bug.cgi?id=152345">bug 152345</a>
        <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Attachment #267593 Flags</td>
           <td>review?
           </td>
           <td>review-
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Teach dashboard code to compare non-integer revisions."
   href="https://bugs.webkit.org/show_bug.cgi?id=152345#c7">Comment # 7</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Teach dashboard code to compare non-integer revisions."
   href="https://bugs.webkit.org/show_bug.cgi?id=152345">bug 152345</a>
              from <span class="vcard"><a class="email" href="mailto:dean_johnson&#64;apple.com" title="Dean Johnson &lt;dean_johnson&#64;apple.com&gt;"> <span class="fn">Dean Johnson</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=267593&amp;action=diff" name="attach_267593" title="Patch">attachment 267593</a> <a href="attachment.cgi?id=267593&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=267593&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=267593&amp;action=review</a>

Looks good overall. Few things, but otherwise nice work... I know a lot of people will be happy to see these changes merged. :)

Also, thanks for adding QUnit! It's awesome that we have a way to test our front-end now.

<span class="quote">&gt; Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotQueue.js:301
&gt;          var sortedRepositories = Dashboard.sortedRepositories;
&gt;          for (var i = 0; i &lt; sortedRepositories.length; ++i) {
&gt;              var repositoryName = sortedRepositories[i].name;
&gt; -            var result = b.revision[repositoryName] - a.revision[repositoryName];
&gt; +            var trac = sortedRepositories[i].trac;
&gt; +            if (!trac || b.revision[repositoryName] === undefined || a.revision[repositoryName] === undefined)
&gt; +                return undefined;
&gt; +            var result = trac.compareRevisions(b.revision[repositoryName], a.revision[repositoryName]);
&gt;              if (result)
&gt;                  return result;
&gt;          }</span >

Could compareIterations and compareIterationsByRevisions share this piece of code? It looks identical.

<span class="quote">&gt; Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/Trac.js:272
&gt; +    compareRevisions: function(a, b)
&gt; +    {
&gt; +        var indexA = this.recordedCommits.objectIndexOf(a, &quot;revisionNumber&quot;);
&gt; +        var indexB = this.recordedCommits.objectIndexOf(b, &quot;revisionNumber&quot;);
&gt; +        if (indexA === undefined || indexB === undefined) {
&gt; +            this.loadMoreHistoricalData();
&gt; +            return undefined;
&gt; +        }
&gt; +        return indexA - indexB;
&gt; +    },</span >

This seems to make the assumption that a &gt; b. Is it ever possible that b &gt; a? If so, maybe use indexA as max(IndexA, indexB) and indexB as min(indexA, indexB).

<span class="quote">&gt; Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/Utilities.js:170
&gt; +{</span >

I think this may make more sense as something like: indexOfObjectWithProperty. I don't like how verbose that is necessarily though, but it does seem a bit confusing without reading the function code. Ideas?

<span class="quote">&gt; Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/Utilities.js:172
&gt; +        if (this[i][property] === searchTerm) return i;</span >

Nit: I think this would look a little nicer on two lines.

<span class="quote">&gt; Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/tests/MockOverrides.js:5
&gt; +        if (x) {</span >

What is x? Could we use a better variable?</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>