<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:ap&#64;webkit.org" title="Alexey Proskuryakov &lt;ap&#64;webkit.org&gt;"> <span class="fn">Alexey Proskuryakov</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - WebCrypto: RSASSA-PKCS1-v1_5 generated keys can not be exported"
   href="https://bugs.webkit.org/show_bug.cgi?id=144938">bug 144938</a>
        <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Attachment #264914 Flags</td>
           <td>review?
           </td>
           <td>review-
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - WebCrypto: RSASSA-PKCS1-v1_5 generated keys can not be exported"
   href="https://bugs.webkit.org/show_bug.cgi?id=144938#c14">Comment # 14</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - WebCrypto: RSASSA-PKCS1-v1_5 generated keys can not be exported"
   href="https://bugs.webkit.org/show_bug.cgi?id=144938">bug 144938</a>
              from <span class="vcard"><a class="email" href="mailto:ap&#64;webkit.org" title="Alexey Proskuryakov &lt;ap&#64;webkit.org&gt;"> <span class="fn">Alexey Proskuryakov</span></a>
</span></b>
        <pre>Comment on <span class=""><a href="attachment.cgi?id=264914&amp;action=diff" name="attach_264914" title="Patch">attachment 264914</a> <a href="attachment.cgi?id=264914&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=264914&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=264914&amp;action=review</a>

Looks good to me. Marking r- because there are minor nits that needs to be addressed.

<span class="quote">&gt; Source/WebCore/bindings/js/JSCryptoAlgorithmDictionary.cpp:49
&gt; +enum HashRequirement {</span >

Please use a strongly typed enum (enum class).

<span class="quote">&gt; Source/WebCore/bindings/js/JSCryptoAlgorithmDictionary.cpp:50
&gt; +    HashIsOptional = 0,</span >

No need for a value here.

<span class="quote">&gt; Source/WebCore/bindings/js/JSCryptoAlgorithmDictionary.cpp:121
&gt; +        if (HashIsRequired == isRequired)</span >

While it is sometimes recommended to put constants at the left to avoid accidental assignment, this is not a style we use in WebKit. We prefer readability over catching such mistakes, which are caught by compiler warnings and by tests anyway.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>