<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Add support for new.target."
href="https://bugs.webkit.org/show_bug.cgi?id=147051#c11">Comment # 11</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Add support for new.target."
href="https://bugs.webkit.org/show_bug.cgi?id=147051">bug 147051</a>
from <span class="vcard"><a class="email" href="mailto:utatane.tea@gmail.com" title="Yusuke Suzuki <utatane.tea@gmail.com>"> <span class="fn">Yusuke Suzuki</span></a>
</span></b>
<pre>Comment on <span class=""><a href="attachment.cgi?id=257099&action=diff" name="attach_257099" title="Patch">attachment 257099</a> <a href="attachment.cgi?id=257099&action=edit" title="Patch">[details]</a></span>
Patch
View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=257099&action=review">https://bugs.webkit.org/attachment.cgi?id=257099&action=review</a>
<span class="quote">>>> Source/JavaScriptCore/parser/ASTBuilder.h:183
>>> + ExpressionNode* newTargetExpr(const JSTokenLocation location)
>>
>> small nit: We usually try to name things that create AST nodes "createX".
>> So here, "createNewTargetNode" or "createNewTargetExpression".
>
> Is there a reason why thisExpr and superExpr don't follow this rule? I named my function "newTargetExpr" since new.target is similar to this but for constructors, so I was trying to emulate those functions.</span >
Ah, I guess they are just overlooked ones. Could you rename them to createThisExpr, createSuperExpr etc. at the same time?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>