<html>
<head>
<base href="https://bugs.webkit.org/" />
</head>
<body>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Function allocation sinking works for wrong reasons"
href="https://bugs.webkit.org/show_bug.cgi?id=144176#c7">Comment # 7</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Function allocation sinking works for wrong reasons"
href="https://bugs.webkit.org/show_bug.cgi?id=144176">bug 144176</a>
from <span class="vcard"><a class="email" href="mailto:basile_clement@apple.com" title="Basile Clement <basile_clement@apple.com>"> <span class="fn">Basile Clement</span></a>
</span></b>
<pre>(In reply to <a href="show_bug.cgi?id=144176#c6">comment #6</a>)
<span class="quote">> Comment on <span class=""><a href="attachment.cgi?id=251764&action=diff" name="attach_251764" title="Seems to be doing the right thing">attachment 251764</a> <a href="attachment.cgi?id=251764&action=edit" title="Seems to be doing the right thing">[details]</a></span>
> Seems to be doing the right thing
>
> View in context:
> <a href="https://bugs.webkit.org/attachment.cgi?id=251764&action=review">https://bugs.webkit.org/attachment.cgi?id=251764&action=review</a>
>
> >> Source/JavaScriptCore/dfg/DFGObjectAllocationSinkingPhase.cpp:812
> >> + if (target->op() != NewObject)
> >
> > Unsure if I should add a helper function in DFG::Node for that...
>
> Seems wrong - MaterializeNewObject is also a sink candidate.</span >
Oh, duh, indeed. Fixing that, w/ a helper function then.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are the assignee for the bug.</li>
</ul>
</body>
</html>