<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - AX: richer text change notifications"
   href="https://bugs.webkit.org/show_bug.cgi?id=142719#c105">Comment # 105</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - AX: richer text change notifications"
   href="https://bugs.webkit.org/show_bug.cgi?id=142719">bug 142719</a>
              from <span class="vcard"><a class="email" href="mailto:d_russell&#64;apple.com" title="Doug Russell &lt;d_russell&#64;apple.com&gt;"> <span class="fn">Doug Russell</span></a>
</span></b>
        <pre>(In reply to <a href="show_bug.cgi?id=142719#c104">comment #104</a>)
<span class="quote">&gt; &gt; &gt; Source/WebCore/editing/ReplaceInsertIntoTextNodeCommand.h:37
&gt; &gt; &gt; +    static Ref&lt;ReplaceInsertIntoTextNodeCommand&gt; create(PassRefPtr&lt;Text&gt; node, unsigned offset, const String&amp; text, const String&amp; deletedText, EditAction editingAction)
&gt; &gt; 
&gt; &gt; New code should not use PassRefPtr. See
&gt; &gt; &lt;<a href="https://www.webkit.org/coding/RefPtr.html">https://www.webkit.org/coding/RefPtr.html</a>&gt;.
&gt; &gt; 
&gt; &gt; &gt; Source/WebCore/editing/ReplaceInsertIntoTextNodeCommand.h:43
&gt; &gt; &gt; +    ReplaceInsertIntoTextNodeCommand(PassRefPtr&lt;Text&gt;, unsigned, const String&amp;, const String&amp;, EditAction);
&gt; &gt; 
&gt; &gt; New code should not use PassRefPtr. See
&gt; &gt; &lt;<a href="https://www.webkit.org/coding/RefPtr.html">https://www.webkit.org/coding/RefPtr.html</a>&gt;.
&gt; 
&gt; Switching these methods to RefPtr results in style errors:
&gt; ERROR: Source/WebCore/editing/ReplaceDeleteFromTextNodeCommand.cpp:33:  The
&gt; parameter type should use PassRefPtr instead of RefPtr. 
&gt; [readability/pass_ptr] [5]
&gt; 
&gt; What's the appropriate type here?</span >

Nevermind, didn't have a &amp;&amp;

<span class="quote">&gt; Function arguments
&gt;  If a function does not take ownership of an object, the argument should be a raw reference or raw pointer.
&gt;  If a function does take ownership of an object, the argument should be a Ref&amp;&amp; or a RefPtr&amp;&amp;. This includes many setter functions.</span ></pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>