<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] Implement ES6 arrow function syntax"
   href="https://bugs.webkit.org/show_bug.cgi?id=140855#c70">Comment # 70</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [ES6] Implement ES6 arrow function syntax"
   href="https://bugs.webkit.org/show_bug.cgi?id=140855">bug 140855</a>
              from <span class="vcard"><a class="email" href="mailto:gskachkov&#64;gmail.com" title="GSkachkov &lt;gskachkov&#64;gmail.com&gt;"> <span class="fn">GSkachkov</span></a>
</span></b>
        <pre>Comment on <span class="bz_obsolete"><a href="attachment.cgi?id=249968&amp;action=diff" name="attach_249968" title="Patch">attachment 249968</a> <a href="attachment.cgi?id=249968&amp;action=edit" title="Patch">[details]</a></span>
Patch

View in context: <a href="https://bugs.webkit.org/attachment.cgi?id=249968&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=249968&amp;action=review</a>

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:1768
&gt;&gt; +    instructions().append(thisRegister()-&gt;index());
&gt; 
&gt; Are we emitting a TDZ check if an arrow function is used inside a derived class' constructor before super() is called?
&gt; e.g. new (class extends (class {}) { () =&gt; this; super(); }) should throw a ReferenceError instead of crashing.
&gt; 
&gt; Please add a stress test too.</span >

I've added test Source/JavaScriptCore/tests/stress/arrowfunction-tdz.js.

<span class="quote">&gt;&gt; Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp:1772
&gt;&gt; +RegisterID* BytecodeGenerator::emitThisNodeBytecode(RegisterID* dst, JSTextPosition position)
&gt; 
&gt; How is this code different at all from what's in ThisNode::emitBytecode?
&gt; I don't think we should duplicate this much code in two places.</span >

Removed duplication.

<span class="quote">&gt;&gt; Source/JavaScriptCore/jit/JITOperations.cpp:47
&gt;&gt; +#endif
&gt; 
&gt; We should probably be checking this inside JSArrowFunction.h</span >

Done.

<span class="quote">&gt;&gt; Source/JavaScriptCore/jit/JITOperations.h:121
&gt;&gt; +#endif
&gt; 
&gt; I don't think we need to if-def op codes like this.  e.g. op_check_tdz is used only when class syntax is enabled but we don't if-def it.</span >

removed if-def

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:598
&gt;&gt; +    bool correcArrowFinish = isEndOfArrowFunction() || match(EOFTOK);
&gt; 
&gt; Typo: correc*t*.  How is this condition different from autoSemiColon()?
&gt; It seems that we need to document the difference one way or another.</span >

I'll take a look deeper in autoSemiColon(), possible this functions both do the same.

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1198
&gt;&gt; +    bool handled = false;
&gt; 
&gt; This variable is unnecessary.</span >

Done

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1206
&gt;&gt; +            handled = true;
&gt; 
&gt; We should just call context.setEndOffset and return here instead.</span >

Done

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1457
&gt;&gt; +    if (parseType == ArrowFunctionParseType) {
&gt; 
&gt; We should either use switch here or assert that parseType == ArrowFunctionParseType if the previous if evaluated to false.
&gt; Also, can we do a refactoring to put the original code into a separate helper function in a separate patch so that the diff here is readable?
&gt; As is, it's hard to review...</span >

I'll try to refactor to increase patch readability this weekend.

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1528
&gt;&gt;          m_token = cachedInfo-&gt;closeBraceToken();
&gt; 
&gt; Can't we just add endFunctionToken to cacheInfo instead?</span >

Introduced new function with name endFunctionToken instead of closeBraceToken() &amp; endArrowFunctionToken

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1544
&gt;&gt; +            next();
&gt; 
&gt; !?  Why not (parseType != ArrowFunctionParseType || info.arrowFunctionBodyType == ArrowFunctionBodyBlock)?</span >

Fixed

<span class="quote">&gt;&gt; Source/JavaScriptCore/parser/Parser.cpp:1629
&gt;&gt; +        } else
&gt; 
&gt; It looks like these two conditions can be combined into parseType == ArrowFunctionParseType &amp;&amp; info.arrowFunctionBodyType != ArrowFunctionBodyBlock
&gt; to run the code in else since the statement in the inner if and the outer else are identical.</span >

Done</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>