<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [GTK] Invalid cast from 'WebKitDOMHTMLElement' to 'WebKitDOMHTMLFormElement'"
   href="https://bugs.webkit.org/show_bug.cgi?id=137743#c8">Comment # 8</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [GTK] Invalid cast from 'WebKitDOMHTMLElement' to 'WebKitDOMHTMLFormElement'"
   href="https://bugs.webkit.org/show_bug.cgi?id=137743">bug 137743</a>
              from <span class="vcard"><a class="email" href="mailto:alpine.art.de@gmail.com" title="alpine.art.de@gmail.com">alpine.art.de@gmail.com</a>
</span></b>
        <pre>Issue fixed! By compiling with clang.
The problematic build was done with gcc-4.9.2.
C{XX}FLAGS="-march=corei7-avx -O2 -pipe"

CPU:
vendor_id       : GenuineIntel
cpu family      : 6
model           : 42
model name      : Intel(R) Core(TM) i3-2350M CPU @ 2.30GHz
stepping        : 7
microcode       : 0x1b
cpu MHz         : 1156.828
cache size      : 3072 KB

I had jit enabled and that seems to depend on LLVM. Already thought of disabling that while keep building with gcc, but I decided to give clang a chance - and succeeded. My machine is quite slow, so recompiling webkit just for testing is not that much fun ;)

So I'm back on happy holiday hacking :)</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>