[Webkit-unassigned] [Bug 279233] New: Rename BlockFlowDirection to FlowDirection for better re-use

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 5 16:02:10 PDT 2024


https://bugs.webkit.org/show_bug.cgi?id=279233

            Bug ID: 279233
           Summary: Rename BlockFlowDirection to FlowDirection for better
                    re-use
           Product: WebKit
           Version: WebKit Local Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Layout and Rendering
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: fantasai.bugs at inkedblade.net
                CC: bfulgham at webkit.org, simon.fraser at apple.com,
                    zalan at apple.com

We currently have a BlockFlowDirection enum for returning the block flow direction:

enum class BlockFlowDirection : uint8_t {
    TopToBottom,
    BottomToTop,
    LeftToRight,
    RightToLeft,
};

Renaming it to FlowDirection would allow it to be re-used in additional contexts that need a flow direction--which would also mean that utility functions that compute against it can also be re-used. It's also slightly shorter, so lines using its literals are less likely to wrap awkwardly.

The fact that it's about the block axis is generally clear from e.g. the variable names, so we're lot losing any clarity by doing this.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20240905/9c715b81/attachment.htm>


More information about the webkit-unassigned mailing list