[Webkit-unassigned] [Bug 274723] New: Refactor LLInt::Data::performAssertions() into assertInvariants().

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat May 25 20:51:48 PDT 2024


https://bugs.webkit.org/show_bug.cgi?id=274723

            Bug ID: 274723
           Summary: Refactor LLInt::Data::performAssertions() into
                    assertInvariants().
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

The intent of LLInt::Data::performAssertions() was to assert some invariants that cannot be expressed as static_asserts, or did not have a convenient place to express the static_asserts because they are about constants used in the LLInt asm files.  These asserts need only be executed once.  At the time, I added a call to performAssertions() from the VM constructor.  The better place to call it would be from JSC::initialize(), which is only executed once per process.

Additionally, over time, we started using this function to assert other invariants.  Hence, we should rename it and put it in a place not associated with the LLInt specifically.

Lastly, replace all uses of the antiquated STATIC_ASSERT macro with static_assert.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20240526/f0c09e57/attachment.htm>


More information about the webkit-unassigned mailing list