[Webkit-unassigned] [Bug 272277] New: CSS Styles are not applied when using JavaScript Modules

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 6 01:44:14 PDT 2024


https://bugs.webkit.org/show_bug.cgi?id=272277

            Bug ID: 272277
           Summary: CSS Styles are not applied when using JavaScript
                    Modules
           Product: WebKit
           Version: Safari 17
          Hardware: iPhone / iPad
                OS: iOS 17
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: CSS
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: king-sora at hotmail.de

Created attachment 470780

  --> https://bugs.webkit.org/attachment.cgi?id=470780&action=review

Reproduction HTML File

Observing CSS styles beeing not applied when opening the attached HTML file for the first time.
This is reproducable in the latest webkit version and on Safari iOS version 17.

Steps:
- Open icognito tab. (Optional for consistent results)
- Open the attached HTML File.
- Observe the number displayed. If styles are applied correctly the value should be "222", if it is any other number styles are not applied.
- On iOS version 17 for the first load the number is not "222", for every subsequent load it is "222".
- On Webkit the number is never "222".

Notes:
- When I remove `type="module"` from the script element the number is consistently "222" for every load.
- When I remove the external stylesheet in the head the number is consistently "222" for every load.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20240406/023d0fdf/attachment.htm>


More information about the webkit-unassigned mailing list