[Webkit-unassigned] [Bug 257082] Changing 'DisplayType::InlineGrid' and 'DisplayType::InlineFlex' to output properly in StyleAdjuster.cpp

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat May 20 08:48:49 PDT 2023


https://bugs.webkit.org/show_bug.cgi?id=257082

--- Comment #3 from Ahmad Saleem <ahmad.saleem792 at gmail.com> ---
(In reply to zalan from comment #2)
> (In reply to Ahmad Saleem from comment #0)
> > Hi Team,
> > 
> > While trying to fix another bug, I came across another fix to failing
> > testcase for following WPT test:
> > 
> > WPT Test: legend-grid-flex-multicol.html & legend-display.html
> > 
> > WPT Test Link (Live):
> > http://wpt.live/html/rendering/non-replaced-elements/the-fieldset-and-legend-
> > elements/legend-grid-flex-multicol.html
> > 
> > ^ Make us pass last two remaining failing tests.
> > 
> > WPT Test: legend-display.html
> > 
> > WPT Test Link (Live):
> > http://wpt.live/html/rendering/non-replaced-elements/the-fieldset-and-legend-
> > elements/legend-display.html
> > 
> > ^ Make us pass more 8 tests cases.
> > 
> > ________________________
> > 
> > WebKit Source to change:
> > 
> > https://github.com/WebKit/WebKit/blob/
> > e17c2153ab908a5821a2b72ee9fe7856b98aac12/Source/WebCore/style/StyleAdjuster.
> > cpp#L116
> > 
> > ^ Change above to following (Partial Copy - diff):
> > 
> >     case DisplayType::Block:
> >     case DisplayType::Table:
> >     case DisplayType::Box:
> >     case DisplayType::FlowRoot:
> >     case DisplayType::ListItem:
> >         return display;
> >     case DisplayType::InlineTable:
> >         return DisplayType::Table;
> >     case DisplayType::InlineBox:
> >         return DisplayType::InlineBox;
> >     case DisplayType::Flex:
> >         return DisplayType::Flex;
> >     case DisplayType::InlineFlex:
> >         return DisplayType::InlineFlex;
> >     case DisplayType::Grid:
> >         return DisplayType::Grid;
> >     case DisplayType::InlineGrid:
> >         return DisplayType::InlineGrid;
> >     case DisplayType::Inline:
> >     case DisplayType::InlineBlock:
> > 
> > _____________________________________
> > ^ Just wanted to raise so we can look into it.
> > 
> > Thanks!
> equivalentBlockDisplay (as the name implies) is supposed to return the block
> version of an inline type of value.
> >     case DisplayType::InlineFlex:
> >         return DisplayType::InlineFlex;
> would certainly break this contract.

Creating separate function for 'Legend' & 'Fieldset' and then using it?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20230520/7f5e053d/attachment.htm>


More information about the webkit-unassigned mailing list