[Webkit-unassigned] [Bug 229485] HTMLVideoElement.currentTime keeps zero for audio source if HTMLVideoElement.muted is true

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 28 04:48:01 PDT 2023


https://bugs.webkit.org/show_bug.cgi?id=229485

Ahmad Saleem <ahmad.saleem792 at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |ahmad.saleem792 at gmail.com

--- Comment #2 from Ahmad Saleem <ahmad.saleem792 at gmail.com> ---
Something like this:

<!DOCTYPE html>
<html>
<body>

<audio controls>
  <source src="horse.ogg" type="audio/ogg">
  <source src="horse.mp3" type="audio/mpeg">
Your browser does not support the audio element.
</audio>

<video muted controls>
<source src="horse.mp3" type="audio/mpeg">
</video>

<script>
const video = document.createElement('video');
video.src = 'horse.mp3';
video.loop = true;
video.muted = true;
const check = () => {
  setTimeout(check, 1000);
  console.log(video.currentTime);
};
check();
</script>

</body>
</html>



I tested and I get '0' multiple events in Safari 16.6, STP175 and Chrome Canary 117, or am I testing it wrong?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20230728/40d3917a/attachment.htm>


More information about the webkit-unassigned mailing list