[Webkit-unassigned] [Bug 259320] New: Yelp help viewer and Epiphany browser do not show content on a virtual machine (llvmpipe?) with webkitgtk 2.41.6

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 18 14:58:49 PDT 2023


https://bugs.webkit.org/show_bug.cgi?id=259320

            Bug ID: 259320
           Summary: Yelp help viewer and Epiphany browser do not show
                    content on a virtual machine (llvmpipe?) with
                    webkitgtk 2.41.6
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: Major
          Priority: P2
         Component: WebKitGTK
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: adamw at happyassassin.net
                CC: bugs-noreply at webkitgtk.org

Since webkitgtk 2.41.6 landed in Fedora Rawhide, the Fedora openQA tests which test that viewing Help pages work are all failing (this includes tests of the installer's Help pages, and tests of various applications that include testing that their Help pages work). In all cases, we see the Yelp application open, but there is no content displayed, just a blank grey rectangle.

openQA tests in (qemu) virtual machines. I can reproduce this problem manually in a local virtual machine - just grab a recent Fedora nightly image, e.g. https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20230718.n.0/compose/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-Rawhide-20230718.n.0.iso , and try running Yelp. I *cannot* reproduce this issue on my bare metal system, so it's most likely to do with the 3D graphics stack, I guess.

Some info requested by mcatanzaro:

1. Running with WEBKIT_DISABLE_COMPOSITING_MODE=1 does indeed work around the issue.
2. Running `WEBKIT_DISABLE_COMPOSITING_MODE=1 epiphany` and browsing to `webkit://gpu` then hitting 'Copy to clipboard' gives me the following:

{
    "Version Information": {
        "WebKit version": "WebKitGTK 2.41.6 (tarball)",
        "Operating system": "Linux 6.5.0-0.rc1.20230711git3f01e9fed845.12.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Wed Jul 12 14:03:10 UTC 2023 x86_64",
        "Desktop": "GNOME",
        "Cairo version": "1.17.8 (build) 1.17.8 (runtime)",
        "GStreamer version": "1.22.4 (build) GStreamer 1.22.4 (runtime)",
        "GTK version": "4.11.4 (build) 4.11.4 (runtime)"
    },
    "Display Information": {
        "Type": "Wayland",
        "Screen geometry": "0,0 1280x800",
        "Screen work area": "0,0 1280x800",
        "Depth": "24",
        "Bits per color component": "8",
        "DPI": "96"
    },
    "Hardware Acceleration Information": {
        "Policy": "never",
        "WebGL enabled": "Yes"
    }
}

Without WEBKIT_DISABLE_COMPOSITING_MODE=1 I can't see anything in the Epiphany window (i.e. it suffers from the same bug).

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20230718/9e95e33f/attachment-0001.htm>


More information about the webkit-unassigned mailing list