[Webkit-unassigned] [Bug 252323] New: [margin-trim] Change shouldChildInlineMarginContributeToContainerIntrinsicSize to be a virtual method on RenderBlock

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 15 10:02:34 PST 2023


            Bug ID: 252323
           Summary: [margin-trim] Change
                    ize to be a virtual method on RenderBlock
           Product: WebKit
           Version: WebKit Local Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Layout and Rendering
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: sgill26 at apple.com
                CC: bfulgham at webkit.org, simon.fraser at apple.com,
                    zalan at apple.com

It is a little strange in the way that we currently use this method (immediately downcast to RenderBlockFlow). It would be a better interface if it was a virtual method on RenderBlock and gets overridden in RenderBlockFlow

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20230215/e555ad0a/attachment.htm>

More information about the webkit-unassigned mailing list