[Webkit-unassigned] [Bug 254757] SVGPathSegValue::clone<>() rename to SVGPathSegValue::cloneInternal<>()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 6 13:41:17 PDT 2023


https://bugs.webkit.org/show_bug.cgi?id=254757

Said Abou-Hallawa <sabouhallawa at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|SVGPathSegValue<PathSegType |SVGPathSegValue::clone<>()
                   |>::clone hides              |rename to
                   |SVGPathSeg::clone           |SVGPathSegValue::cloneInter
                   |                            |nal<>()

--- Comment #3 from Said Abou-Hallawa <sabouhallawa at apple.com> ---
I think this might be a bug or limitation in GCC 13 complier. The clang complier considers the template function SVGPathSegValue::clone<>() different from the virtual function SVGPathSeg::clone() so it does not generate an error saying the template function hides the virtual implementations.

Open LayoutTests/svg/dom/SVGPathSegList-insert-from-animating-animPathSegList.svg in the debugger and set a breakpoint in SVGPathSegMovetoAbs::clone(). In Xcode the debugger breaks at the function.

SVGPathSegValue::clone<>() should be renamed to SVGPathSegValue::cloneInternal<>(). So the code can be complied on GCC 13 without the need for -Woverloaded-virtual.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20230406/c286f375/attachment-0001.htm>


More information about the webkit-unassigned mailing list