[Webkit-unassigned] [Bug 242409] New: [WPE][GTK] Decide on conditional name for new API versions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 6 12:54:41 PDT 2022


https://bugs.webkit.org/show_bug.cgi?id=242409

            Bug ID: 242409
           Summary: [WPE][GTK] Decide on conditional name for new API
                    versions
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebKitGTK
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mcatanzaro at gnome.org
                CC: bugs-noreply at webkitgtk.org
            Blocks: 210100

I'm trying to decide on a single conditional I can use to distinguish between new API and old API. Example usage:

#if PLATFORM(GTK) && WEBKITGTK_API_VERSION >= 5.0 || PLATFORM(WPE) && WPE_API_VERSION >= 2.0
// do new thing
#else
// do old thing
#endif

Except that's too verbose, so we should have something much shorter, ideally with no && or || at all.

#if ENABLE(NEW_GLIB_APIS)
#if ENABLE(MODERN_WPE_GTK_API)
#if ENABLE(2022_API_VERSION)
#if ENABLE(2022_GLIB_API)
#if ENABLE(SOME_CODEWORD)

Ideas and/or votes welcome. This is a bikeshedding bug report.


Referenced Bugs:

https://bugs.webkit.org/show_bug.cgi?id=210100
[Bug 210100] [META][GTK][GTK4] Support GTK4
-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220706/799eaab3/attachment.htm>


More information about the webkit-unassigned mailing list