[Webkit-unassigned] [Bug 242301] New: Rename offlineasm's asm.deferAction to asm.deferOSDarwinAction.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Sun Jul 3 18:43:06 PDT 2022
https://bugs.webkit.org/show_bug.cgi?id=242301
Bug ID: 242301
Summary: Rename offlineasm's asm.deferAction to
asm.deferOSDarwinAction.
Product: WebKit
Version: WebKit Nightly Build
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: JavaScriptCore
Assignee: webkit-unassigned at lists.webkit.org
Reporter: mark.lam at apple.com
Similarly, rename the underlying field from @deferredAction to @deferredOSDarwinAction. This deferAction was only used for OS(DARWIN) anyway. By changing it to be OS(DARWIN) specific to indicate its actual usage, we can make the generated LLIntAssembly.h more readable and efficient.
Previously, we emit this code:
OFFLINE_ASM_GLOBAL_LABEL(llintPCRangeEnd)
#if OS(DARWIN)
".loh AdrpLdrGot Ljsc_llint_loh_adrp_1, Ljsc_llint_loh_ldr_1 \n"
#endif
#if OS(DARWIN)
".loh AdrpLdrGot Ljsc_llint_loh_adrp_2, Ljsc_llint_loh_ldr_2 \n"
#endif
...
#if OS(DARWIN)
".loh AdrpLdrGot Ljsc_llint_loh_adrp_2308, Ljsc_llint_loh_ldr_2308 \n"
#endif
OFFLINE_ASM_END
Now, we emit this instead:
OFFLINE_ASM_GLOBAL_LABEL(llintPCRangeEnd)
#if OS(DARWIN)
".loh AdrpLdrGot Ljsc_llint_loh_adrp_1, Ljsc_llint_loh_ldr_1 \n"
".loh AdrpLdrGot Ljsc_llint_loh_adrp_2, Ljsc_llint_loh_ldr_2 \n"
...
".loh AdrpLdrGot Ljsc_llint_loh_adrp_2308, Ljsc_llint_loh_ldr_2308 \n"
#endif // OS(DARWIN)
OFFLINE_ASM_END
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220704/2262c088/attachment-0001.htm>
More information about the webkit-unassigned
mailing list