[Webkit-unassigned] [Bug 235214] New: AX: Rename AXDisabledStateChanged to the more accurate AXAriaDisabledChanged

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 13 17:38:28 PST 2022


            Bug ID: 235214
           Summary: AX: Rename AXDisabledStateChanged to the more accurate
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Accessibility
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: tyler_w at apple.com
                CC: andresg_22 at apple.com,
                    webkit-bug-importer at group.apple.com

We have a notification called AXDisabledStateChanged that is issued when the aria-disabled attribute changes. However, the disabled attribute can also cause this state change. I would like to rename AXDisabledStateChanged to AXAriaDisabledChanged so that we can be more granular in isolated tree updates. Specifically, in AccessibilityNodeObject::isEnabled(), when aria-disabled changes for an element, we'll need to invalidate AXPropertyName::IsEnabled for all descendants. The same work would not be required if the disabled attribute changed, so smashing both changes into AXDisabledStateChanged will cost performance.

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220114/fa855390/attachment.htm>

More information about the webkit-unassigned mailing list