[Webkit-unassigned] [Bug 234865] Add a helper function that returns the value of a std::optional<T> or constructs T if needed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 4 17:18:31 PST 2022


https://bugs.webkit.org/show_bug.cgi?id=234865

--- Comment #1 from Wenson Hsieh <wenson_hsieh at apple.com> ---
I found 116 instances in WebKit where we can replace this:

```
optional.value_or(InnerType { })
```

...with this:

```
valueOrDefault(optional)
```

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220105/422b0a18/attachment.htm>


More information about the webkit-unassigned mailing list