[Webkit-unassigned] [Bug 237060] Queue throwing exception of blob objects during destruction

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 22 15:06:33 PST 2022


https://bugs.webkit.org/show_bug.cgi?id=237060

--- Comment #7 from Mark Lam <mark.lam at apple.com> ---
Comment on attachment 452903
  --> https://bugs.webkit.org/attachment.cgi?id=452903
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=452903&action=review

>> Source/WebCore/fileapi/Blob.cpp:289
>> +            if (!heap.isShuttingDown()) {
> 
> Let's add VM::isShuttingDown() getter and use it instead of touching heap directly here.
> Heap and VM can become different after global GC. So for now, VM::isShuttingDown() implementation should be `return heap.isShuttingDown()`.
> But we should avoid touching heap directly here.

Yeah, sorry about that: I told Brandon that he doesn't have to do this because I wasn't sure that the VM method should be called because the period of time for which Heap shut down flag is only a subset of the period of time during VM shut down, nor whether we do need to make a distinction between the two.  But on second thought, I suppose calling it `VM::isShuttingDown()` is appropriate for now.  We can always change its implementation later if we need to redefine it.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220222/f2de6bbe/attachment.htm>


More information about the webkit-unassigned mailing list