[Webkit-unassigned] [Bug 249495] New: Introduce CallFrame::returnPCForInspection(), and removed some unused code.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 16 12:49:43 PST 2022


https://bugs.webkit.org/show_bug.cgi?id=249495

            Bug ID: 249495
           Summary: Introduce CallFrame::returnPCForInspection(), and
                    removed some unused code.
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

CallFrame::returnPC() was relying on ReturnAddressPtr, which in turn expected to be able to untag any arbitrary return address read from a stack frame.  This will not always be possible when JITCage is enabled.  Also, CallFrame::returnPC() is only used for debugging purposes.  So, this patch will simplify its implementation and rename it to CallFrame::returnPCForInspection() to make it clear that it should only be used for debugging and analysis purposes.

We will also remove some related unused code.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20221216/6b4fc269/attachment.htm>


More information about the webkit-unassigned mailing list