[Webkit-unassigned] [Bug 248682] New: Clean up some options initialization workflow.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Dec 2 13:27:47 PST 2022
https://bugs.webkit.org/show_bug.cgi?id=248682
Bug ID: 248682
Summary: Clean up some options initialization workflow.
Product: WebKit
Version: WebKit Nightly Build
Hardware: Unspecified
OS: Unspecified
Status: NEW
Severity: Normal
Priority: P2
Component: JavaScriptCore
Assignee: webkit-unassigned at lists.webkit.org
Reporter: mark.lam at apple.com
We always call correctOptions() before recomputeDependentOptions(), and often call dumpOptionsIfNeeded() and ensureOptionsAreCoherent() after.
This patch makes things more consistent by:
1. Rename recomputeDependentOptions() to notifyOptionsChanged().
2. Rename ensureOptionsAreCoherent() to assertOptionsAreCoherent(), because "ensure" implies that the function will make them coherent. Instead, the function asserts that they are coherent.
3. Move the body of correctOptions() (which is a tiny function) into the top of notifyOptionsChanged().
4. Call dumpOptionsIfNeeded() and assertOptionsAreCoherent() at the end of notifyOptionsChanged() instead of from clients.
5. Make sure clients call notifyOptionsChanged() after changing options.
Additionally:
6. Rename ExecutableAllocator:: setJITEnabled() to ExecutableAllocator::disableJIT(). Disabling JIT in this function was always a one way street, and there's no going back. This rename makes it clear and explicit.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20221202/0c21a849/attachment.htm>
More information about the webkit-unassigned
mailing list