[Webkit-unassigned] [Bug 244128] Add experimental feature to disable image animations
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Aug 19 14:13:47 PDT 2022
https://bugs.webkit.org/show_bug.cgi?id=244128
--- Comment #3 from chris fleizach <cfleizach at apple.com> ---
Comment on attachment 461738
--> https://bugs.webkit.org/attachment.cgi?id=461738
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=461738&action=review
> Source/WebCore/html/HTMLImageElement.cpp:787
> + if (auto* cachedImage = this->cachedImage()) {
looks like a lot of duplicated code here - can you condense into helper methods
> Source/WebCore/svg/graphics/SVGImage.cpp:382
> + if (!rootElement || !rootElement->animationsPaused() || m_page->settings().animatedImagesDisabled())
do we need to check m_page for not nil?
> Source/WebCore/testing/Internals.cpp:1061
> + Document* document = contextDocument();
auto*
> Source/WebCore/testing/Internals.cpp:1065
> + Page* page = document->page();
auto*
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20220819/ea63b683/attachment.htm>
More information about the webkit-unassigned
mailing list