[Webkit-unassigned] [Bug 230874] Adopt presentationSceneIdentifierForPaymentAuthorizationController delegate call from PassKit

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 29 15:24:30 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=230874

--- Comment #5 from Devin Rousso <drousso at apple.com> ---
Comment on attachment 439632
  --> https://bugs.webkit.org/attachment.cgi?id=439632
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=439632&action=review

> Source/WebKit/Platform/ios/PaymentAuthorizationController.h:54
> +    void presentInScene(const String&, CompletionHandler<void(bool)>&&) final;

NIT: this should above any member variables, probably right below `present`

> Source/WebKit/Shared/ApplePay/WebPaymentCoordinatorProxy.h:96
> +        virtual void paymentCoordinatorPresentingWindowSceneIdentifier(WebPageProxyIdentifier, CompletionHandler<void(const String&)>&&) = 0;

NIT: I'd also rename this to `getWindowSceneIdentifierForPaymentPresentation` so that it makes code searching easier (e.g. same method name in the NetworkProcess code and UIProcess code) and for the same reason as the last patch

> Source/WebKit/Shared/ApplePay/ios/WebPaymentCoordinatorProxyIOS.mm:61
> +            weakThis->m_authorizationPresenter->presentInScene(sceneID, WTFMove(completionHandler));

see my comment on your last patch about this

> Source/WebKit/UIProcess/Network/NetworkProcessProxy.h:261
> +    void getWindowSceneIdentifierForPaymentPresentation(WebPageProxyIdentifier, CompletionHandler<void(String)>&&);

Can we `const String&`?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210929/305817c2/attachment-0001.htm>


More information about the webkit-unassigned mailing list