[Webkit-unassigned] [Bug 231963] WebAuthn Platform UI callbacks are not guaranteed to happen on the main thread
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Oct 19 12:02:34 PDT 2021
https://bugs.webkit.org/show_bug.cgi?id=231963
Brent Fulgham <bfulgham at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #441763|review? |review+, commit-queue-
Flags| |
--- Comment #5 from Brent Fulgham <bfulgham at webkit.org> ---
Comment on attachment 441763
--> https://bugs.webkit.org/attachment.cgi?id=441763
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=441763&action=review
r=me, but please adjust the 'protectedThis' naming to reflect that this is a weak pointer, and does not hold the instance alive.
> Source/WebKit/UIProcess/WebAuthentication/Cocoa/WebAuthenticatorCoordinatorProxy.mm:270
> + auto protectedThis = weakThis.get();
protectedThis is a bad name for a WeakPtr -- can we just use 'weakThis'? I don't think we need to pull a bare pointer out of the WeakPtr wrapper (it should cast properly). 'protectedThis' implies we have a RetainPtr that is holding the object alive -- which is misleading in this case.
> Source/WebKit/UIProcess/WebAuthentication/Cocoa/WebAuthenticatorCoordinatorProxy.mm:271
> + if (!protectedThis || !daemonEndpoint) {
So this would just be "if (!weakThis || !daemonEndpoint) {"
> Source/WebKit/UIProcess/WebAuthentication/Cocoa/WebAuthenticatorCoordinatorProxy.mm:277
> + protectedThis->m_presenter = adoptNS([allocASCAuthorizationRemotePresenterInstance() init]);
Then these could just be "weakThis->m_presenter", etc.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20211019/600e6bc1/attachment.htm>
More information about the webkit-unassigned
mailing list