[Webkit-unassigned] [Bug 189513] Wrong static position for out-of-flow positioned element with different writing-mode than its containing block
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed May 12 07:26:19 PDT 2021
https://bugs.webkit.org/show_bug.cgi?id=189513
--- Comment #16 from Oriol Brufau <obrufau at igalia.com> ---
Comment on attachment 428366
--> https://bugs.webkit.org/attachment.cgi?id=428366
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=428366&action=review
> Source/WebCore/rendering/RenderBox.cpp:3556
> +static inline bool childIsVLRParentInHTB(const RenderBox* child)
The name seems confusing to me, sounds like "child is parent". Maybe isVerticalLrChildInHorizontalTbParent?
> Source/WebCore/rendering/RenderBox.cpp:3561
> + if (!child->isHorizontalWritingMode() && parent->isHorizontalWritingMode() && child->style().isFlippedLinesWritingMode() && !parent->style().isFlippedBlocksWritingMode())
> + return true;
> + return false;
Instead of
if (cond)
return true;
return false;
this could just be
return cond;
> Source/WebCore/rendering/RenderBox.cpp:3598
> staticPosition += renderBox.logicalLeft();
Missing indentation.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210512/ae15d1e2/attachment-0001.htm>
More information about the webkit-unassigned
mailing list