[Webkit-unassigned] [Bug 189513] Wrong static position for out-of-flow positioned element with different writing-mode than its containing block

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 11 04:23:54 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=189513

--- Comment #13 from Sergio Villar Senin <svillar at igalia.com> ---
Comment on attachment 427863
  --> https://bugs.webkit.org/attachment.cgi?id=427863
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=427863&action=review

> Source/WebCore/rendering/RenderBox.cpp:3573
> +        if (!child->isHorizontalWritingMode() && parent->isHorizontalWritingMode() && child->style().isFlippedLinesWritingMode() && !parent->style().isFlippedBlocksWritingMode())

We should refactor this condition in  a new inline method with a more descriptive name so we could use it in both this method and in the one bellow as well (in computeBlockStaticDistance() you'll still have to add && parentDirection == TextDirection::LTR but that's fine).

I was thinking about a very descriptive name like childIsVLRinHTBParent(). WDTY?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210511/1494bbd1/attachment.htm>


More information about the webkit-unassigned mailing list