[Webkit-unassigned] [Bug 180633] Wrong position for orthogonal positioned element with writing-mode: vertical-rl

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 6 15:52:33 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=180633

--- Comment #8 from Javier Fernandez <jfernandez at igalia.com> ---
Comment on attachment 427138
  --> https://bugs.webkit.org/attachment.cgi?id=427138
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=427138&action=review

> Source/WebCore/rendering/RenderBox.cpp:4586
> +    if ((this->style().isFlippedBlocksWritingMode() && this->isHorizontalWritingMode() != containerBlock.isHorizontalWritingMode())

I'm not convinced of the approach we are following in this patch. I understand that the problem is that we are not considering the border when computing the logical offset for vertical modes. However, after this change, the computeLogicalLeftPositionedOffset just adds the logical border, and the logic to deal with vertical modes were moved outside; it's now replicated in the classes of the different layout models. 

Additionally, I think this condition to detect cases that need to compute the rtl offset is quite complex and difficult to read. Would it be possible to define a function ? I guess the original idea of the current code was to insert this complex condition inside a computeLogicalLeftPositionedOffset, so that at least it was transparent for the pure layout logic.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210506/3da0a8c4/attachment.htm>


More information about the webkit-unassigned mailing list