[Webkit-unassigned] [Bug 228009] Add key-driven smooth scrolling to macOS

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 21 16:45:34 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=228009

--- Comment #7 from Aditya Keerthi <akeerthi at apple.com> ---
Comment on attachment 433969
  --> https://bugs.webkit.org/attachment.cgi?id=433969
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=433969&action=review

> Source/WebCore/ChangeLog:4
> +                https://bugs.webkit.org/show_bug.cgi?id=228009

Fix indentation.

> Source/WebCore/page/EventHandler.cpp:-70
> -#include "KeyboardEvent.h"

I would keep the `KeyboardEvent` include, since it's still used in this file.

> Source/WebCore/platform/ScrollAnimator.cpp:35
> +#import "EventNames.h"

#include.

> Source/WebCore/platform/ScrollAnimator.cpp:333
> +    ScrollPosition idealPosition = m_scrollableArea.constrainScrollPosition(m_currentScroll ? IntPoint(currentPosition().x(), currentPosition().y()) :  IntPoint(m_idealPosition.x(), m_idealPosition.y()));

This can be written as: `ScrollPosition idealPosition = m_scrollableArea.constrainScrollPosition(IntPoint(m_currentScroll ? currentPosition() : m_idealPosition));`

> Source/WebCore/platform/ScrollController.cpp:-57
> -

Nit: Preserve this whitespace for readability.

> Source/WebCore/platform/ScrollController.h:171
> +    void updateKeyboardScrollingAnimatingState(MonotonicTime);

Nit: Add a newline after this line to preserve the existing organization.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210721/f16afbb5/attachment.htm>


More information about the webkit-unassigned mailing list