[Webkit-unassigned] [Bug 232835] A MediaStreamTrack ended due to a capture failure - When using Airpods

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 20 07:38:24 PST 2021


--- Comment #4 from Tal Bar <tal.bar2005 at gmail.com> ---
Actually, I'm no longer sure that AudioContext is related.. but I'm not ruling it out. 

I'm able to reproduce the issue in many video chat platforms, such as Google Meet and Twilio quickstart React app. 

Steps to reproduce on Google Meet: 

1. Before starting, make sure that your default audio input device is set as your built-in microphone. 
2. Visit https://meet.google.com -> New Meeting -> Start an instant meeting.
3. Allow “meet.google.com” to use your camera and microphone.
4. Go to settings and select a Bluetooth device (I tried with Sony WH-1000XM2) or a USB device (I tried with Logitech C922 Pro Stream Webcam).

The console shows the error "A MediaStreamTrack ended due to a capture failure".
The microphone volume indicator is not moving anymore.

Safari Version 15.2 (17612.
macOS Monterey Version 12.1 (21C52)

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20211220/3d82a1ac/attachment-0001.htm>

More information about the webkit-unassigned mailing list