[Webkit-unassigned] [Bug 233906] Deployment target for macOS 11+ does not follow minor version bumps

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 9 16:02:21 PST 2021


https://bugs.webkit.org/show_bug.cgi?id=233906

Alexey Proskuryakov <ap at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #446620|review?                     |review+
              Flags|                            |

--- Comment #18 from Alexey Proskuryakov <ap at webkit.org> ---
Comment on attachment 446620
  --> https://bugs.webkit.org/attachment.cgi?id=446620
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=446620&action=review

Looks right to me, r=ews.

> Source/WTF/wtf/PlatformHave.h:636
> +#if (PLATFORM(MAC) && __MAC_OS_X_VERSION_MIN_REQUIRED >= 110000) || (PLATFORM(IOS) && __IPHONE_OS_VERSION_MIN_REQUIRED >= 140000)

The iOS version check is not needed, we don't support anything older than iOS 15. So just (PLATFORM(MAC) && __MAC_OS_X_VERSION_MIN_REQUIRED >= 110000) || PLATFORM(IOS).

It is a little unclear to me if this was added in 11.0 or 11.3, but in practice, there is no difference, building or running on 11.0 isn't supported either.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20211210/4be57714/attachment.htm>


More information about the webkit-unassigned mailing list