[Webkit-unassigned] [Bug 233891] New: Remove unneeded virtual allocator methods from Subspace.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 6 12:27:39 PST 2021


https://bugs.webkit.org/show_bug.cgi?id=233891

            Bug ID: 233891
           Summary: Remove unneeded virtual allocator methods from
                    Subspace.
           Product: WebKit
           Version: WebKit Nightly Build
          Hardware: Unspecified
                OS: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
          Assignee: webkit-unassigned at lists.webkit.org
          Reporter: mark.lam at apple.com

Since the virtual allocate() and allocateFor() methods are now deleted, we can also rename the inline allocateNonVirtual() and allocatorForNonVirtual() methods to simply allocate() and allocateFor().  Similarly, rename allocatorForNonVirtualConcurrently() to allocatorForConcurrently().

There are 2 places that still invokes the non-inline version of CompleteSubspace::allocatorFor().  For this reason, we introduce a CompleteSubsace::allocatorForNonInline() to keep the linkage the same.  There's a chance that the compiler/linker may already inline the method in 1 or both of these places, but we'll offer allocatorForNonInline() to keep the code expressing the same thing and let the compiler/linker decide whether to inline it or not just as before.

This is purely a re-factoring patch.  There are no behavior changes, except for the removal of those 2 entries from the vtbls.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20211206/b2357dd5/attachment-0001.htm>


More information about the webkit-unassigned mailing list