[Webkit-unassigned] [Bug 218098] Duplicate checks in overridingContainingBlockContentXXX()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 30 09:18:18 PDT 2021


https://bugs.webkit.org/show_bug.cgi?id=218098

Rob Buis <rbuis at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |rbuis at igalia.com

--- Comment #2 from Rob Buis <rbuis at igalia.com> ---
This is probably not possible. The code wants to distinguish between nullopt as in "there is nothing set" and "there is something set but it is not a number":
    if (logicalHeight.isPercentOrCalculated() && hasOverridingContainingBlockContentLogicalHeight())
        return overridingContainingBlockContentLogicalHeight() == WTF::nullopt;

It may be possible to set some magic value not nullopt for "there is something set but it is not a number" but I don't think it is worth it personally.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210430/4844490e/attachment.htm>


More information about the webkit-unassigned mailing list