[Webkit-unassigned] [Bug 223504] [css-grid] Set hasWidth & hasHeight properties for SVG element's intrinsic size
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Apr 2 03:46:08 PDT 2021
https://bugs.webkit.org/show_bug.cgi?id=223504
--- Comment #4 from zsun at igalia.com ---
(In reply to Javier Fernandez from comment #2)
> Comment on attachment 423712 [details]
> Patch
>
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=423712&action=review
>
> > Source/WebCore/rendering/svg/RenderSVGRoot.cpp:83
> > + intrinsicSize.hasWidth = svgSVGElement().hasIntrinsicWidth();
>
> I'm not sure I understand well enough the meaning of the hasWidth/hasHeight
> attributes. Looking at how you are using it, wouldn't be a clearer name
> something like "isIntrinsicWidth/isIntrinsiHeight" ?
hasWidth/hasHeight here means that whether width/height has been set. Since we are introducing these properties in FloatSize.h, I thought it might be better to make it more generic. When we call intrinsicSize.*, we know that we are referring width/height of the intrinsicSize. Also it's to be inline with has_width/has_height in Chromium for this situation.
--
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20210402/b34332ae/attachment.htm>
More information about the webkit-unassigned
mailing list